Issues uploading files

Incident Report for Boords

Resolved

This incident has been resolved.
Posted Aug 06, 2024 - 15:05 UTC

Investigating

We're currently seeing an elevated error rate with uploads processed through Filestack. We're investigating the issue. In the meantime, we recommend uploading images through our drag and drop feature.
Posted Aug 06, 2024 - 11:58 UTC
This incident affected: Image Delivery, Uploading, and Processing (Filestack API).