Issues with newly created frames

Incident Report for Boords

Resolved

This incident has been resolved.
Posted Aug 09, 2022 - 12:47 UTC

Identified

In some conditions, users might currently experience an issue with creating new frames in bulk or editing the notes of new frames. We've identified the issue and are working towards a fix.
Posted Aug 09, 2022 - 12:19 UTC
This incident affected: Boords (app.boords.com) (Boords Web App).